Tuesday , 25 March 2025
Home » Cisco Switch » A to Z Cisco Nexus Switch Configuration Guide

A to Z Cisco Nexus Switch Configuration Guide

Configuring a Cisco Nexus switch from A to Z involves several steps, from initial setup to advanced configurations. Here’s a complete guide to help you configure your Nexus switch.

A to Z Cisco Nexus Switch Configuration Guide

A. Initial Setup

  1. Console Access:
    • Connect to the switch via the console port using a terminal emulator (e.g., PuTTY).
    • Default baud rate: 9600.
  2. Power On & Initial Boot:
    • Ensure the switch boots correctly and enters the setup wizard.
  3. Exit Setup Wizard (Optional):

    Abort Auto Provisioning and continue with normal setup? (yes/no) [n]: yes
    Do you want to enter the initial configuration dialog? (yes/no) [n]: no

    • Enter privileged EXEC mode:
      switch> enable

B. Basic Configuration

  1. Enter Global Configuration Mode:
    switch# configure terminal
  2. Set the Hostname:
    switch(config)# hostname Nexus-Switch
  3. Set an Admin Password:

    switch(config)# username admin password MySecurePassword role network-admin
  4. Configure Management Interface (OOB Management):

    switch(config)# interface mgmt0 switch(config-if)# ip address 192.168.1.100/24 switch(config-if)# no shutdown switch(config-if)# exit
  5. Set Default Gateway (If Required):

    switch(config)# ip default-gateway 192.168.1.1

C. Enable SSH & Secure Access

  1. Generate SSH Keys:

    switch(config)# feature ssh switch(config)# ssh key rsa 2048 force
  2. Enable Remote Login:

    switch(config)# line vty switch(config-line)# transport input ssh switch(config-line)# exit

D. VLAN Configuration

  1. Create VLANs:

    switch(config)# vlan 10 switch(config-vlan)# name DATA switch(config-vlan)# exit
  2. Assign VLANs to Interfaces:

    switch(config)# interface ethernet1/1 switch(config-if)# switchport mode access switch(config-if)# switchport access vlan 10 switch(config-if)# no shutdown switch(config-if)# exit
  3. Configure a Trunk Port:

    switch(config)# interface ethernet1/2 switch(config-if)# switchport mode trunk switch(config-if)# switchport trunk allowed vlan 10,20,30 switch(config-if)# no shutdown switch(config-if)# exit

E. Layer 3 Configuration

  1. Enable Routing:

    switch(config)# feature interface-vlan switch(config)# feature hsrp switch(config)# ip routing
  2. Create an SVI (Switch Virtual Interface):

    switch(config)# interface vlan 10 switch(config-if)# ip address 192.168.10.1/24 switch(config-if)# no shutdown switch(config-if)# exit
  3. Configure Static Routing (if required):

    switch(config)# ip route 0.0.0.0/0 192.168.1.1

F. Spanning Tree Configuration

  1. Enable Rapid-PVST+ (Per VLAN Spanning Tree):

    switch(config)# spanning-tree mode rapid-pvst switch(config)# spanning-tree vlan 10 priority 4096

G. Port-Channel & VPC (Virtual Port Channel) Configuration

  1. Enable vPC Feature:

    switch(config)# feature vpc
  2. Create a vPC Domain:

    switch(config)# vpc domain 1 switch(config-vpc-domain)# peer-keepalive destination 192.168.1.2 source 192.168.1.1 vrf management
  3. Create Port-Channel & Assign vPC:

    switch(config)# interface port-channel10 switch(config-if)# switchport mode trunk switch(config-if)# vpc 10 switch(config-if)# exit
  4. Assign Interfaces to Port-Channel:

    switch(config)# interface ethernet1/3 switch(config-if)# channel-group 10 mode active switch(config-if)# no shutdown switch(config-if)# exit

H. QoS Configuration (Optional)

  1. Enable QoS Feature:

    switch(config)# feature qos
  2. Apply QoS Policy (Example):

    switch(config)# policy-map QOS-POLICY
    switch(config-pmap)# class class-default
    switch(config-pmap-c)# set dscp 46
    switch(config-pmap-c)# exit

I. Monitoring & Troubleshooting

  1. Show Interface Status:

    switch# show interface brief
  2. Show VLANs:

    switch# show vlan brief
  3. Show Port-Channel Summary:

    switch# show port-channel summary
  4. Show Spanning Tree Status:

    switch# show spanning-tree summary

J. Save Configuration

  1. Save Configuration to Startup Config:

    switch# copy running-config startup-config
  2. Verify Configuration Saved:

    switch# show startup-config

This is a comprehensive guide covering the fundamental steps for configuring a Cisco Nexus switch from start to finish. If you need more advanced configurations like VXLAN, FEX, or specific routing protocols, let me know!

A to Z Cisco Nexus Switch Configuration Guide

HOME

 

Leave a Reply

Your email address will not be published. Required fields are marked *

Translate »